source: osm/applications/editors/josm/debian/rules@ 26608

Last change on this file since 26608 was 15974, checked in by joerg, 15 years ago

remove make commands(no Makefile ;-) , make cleanup more robust

  • Property svn:executable set to *
File size: 1.6 KB
Line 
1#!/usr/bin/make -f
2# Sample debian/rules that uses debhelper.
3# GNU copyright 1997 to 1999 by Joey Hess.
4
5# Uncomment this to turn on verbose mode.
6export DH_VERBOSE=1
7
8# This is the debhelper compatability version to use.
9#export DH_COMPAT=5
10export destdir = $(CURDIR)/debian/openstreetmap-josm
11
12
13build: build-stamp
14build-stamp:
15 dh_testdir
16
17 touch build-stamp
18
19clean:
20 dh_testdir
21 dh_testroot
22 rm -f build-stamp
23 rm -f dist/*.jar
24 rm -f debian/files
25
26 # Add here commands to clean up after the build process.
27 for dir in `ls plugins/*/build.xml | sed s,/build.xml,,`; do \
28 ( cd "$$dir"; \
29 echo "-------- Cleanup Plugin '$$dir' ..."; \
30 rm -f dist/*.jar ../../dist/$dir.jar *.log ; \
31 ant -q clean ); \
32 done
33 cd core; ant -q clean
34 dh_clean
35
36install: build
37 dh_testdir
38 dh_testroot
39 dh_installdirs
40
41# ./debian/update_svn_revision.sh
42 bash ./debian/make_install_files.sh --dest-path=${destdir} --no-clean || exit -1
43 # Install done
44
45# Build architecture-independent files here.
46binary-indep: build install
47 dh_testdir
48 dh_testroot
49 dh_installchangelogs
50 dh_installdebconf
51# dh_installdocs
52# dh_installexamples
53 dh_installmenu
54# dh_installlogrotate
55# dh_installemacsen
56# dh_installpam
57# dh_installmime
58# dh_python
59# dh_installinit
60# dh_installcron
61# dh_installinfo
62# dh_installman
63# dh_link
64 dh_strip
65 dh_compress
66 dh_fixperms
67# dh_perl
68 dh_installdeb
69 dh_gencontrol
70 dh_md5sums
71 dh_builddeb
72
73# Build architecture-dependent files here.
74binary-arch: build install
75# We have nothing to do by default.
76
77binary: binary-arch binary-indep
78.PHONY: build clean binary-indep binary-arch binary install install-indep install-arch
Note: See TracBrowser for help on using the repository browser.