Last change
on this file since 15461 was 12639, checked in by joerg, 16 years ago |
remove old debian/files on clean target
|
-
Property svn:executable
set to
*
|
File size:
1.4 KB
|
Line | |
---|
1 | #!/usr/bin/make -f
|
---|
2 | # Sample debian/rules that uses debhelper.
|
---|
3 | # GNU copyright 1997 to 1999 by Joey Hess.
|
---|
4 |
|
---|
5 | # Uncomment this to turn on verbose mode.
|
---|
6 | export DH_VERBOSE=1
|
---|
7 |
|
---|
8 | # This is the debhelper compatability version to use.
|
---|
9 | #export DH_COMPAT=5
|
---|
10 | export destdir = $(CURDIR)/debian/openstreetmap-josm
|
---|
11 |
|
---|
12 |
|
---|
13 | build: build-stamp
|
---|
14 | build-stamp: clean
|
---|
15 | dh_testdir
|
---|
16 |
|
---|
17 | # Add here commands to compile the package.
|
---|
18 | # $(MAKE)
|
---|
19 |
|
---|
20 | touch build-stamp
|
---|
21 |
|
---|
22 | clean:
|
---|
23 | dh_testdir
|
---|
24 | dh_testroot
|
---|
25 | rm -f build-stamp
|
---|
26 | rm -f dist/*.jar
|
---|
27 | rm -f debian/files
|
---|
28 |
|
---|
29 | # Add here commands to clean up after the build process.
|
---|
30 | -$(MAKE) distclean
|
---|
31 |
|
---|
32 | dh_clean
|
---|
33 |
|
---|
34 | install: build
|
---|
35 | dh_testdir
|
---|
36 | dh_testroot
|
---|
37 | dh_clean -k
|
---|
38 | dh_installdirs
|
---|
39 |
|
---|
40 | # ./debian/update_svn_revision.sh
|
---|
41 | ./debian/make_install_files.sh --dest-path=${destdir} || exit -1
|
---|
42 |
|
---|
43 |
|
---|
44 | # Build architecture-independent files here.
|
---|
45 | binary-indep: build install
|
---|
46 | dh_testdir
|
---|
47 | dh_testroot
|
---|
48 | dh_installchangelogs
|
---|
49 | dh_installdebconf
|
---|
50 | # dh_installdocs
|
---|
51 | # dh_installexamples
|
---|
52 | dh_installmenu
|
---|
53 | # dh_installlogrotate
|
---|
54 | # dh_installemacsen
|
---|
55 | # dh_installpam
|
---|
56 | # dh_installmime
|
---|
57 | # dh_python
|
---|
58 | # dh_installinit
|
---|
59 | # dh_installcron
|
---|
60 | # dh_installinfo
|
---|
61 | # dh_installman
|
---|
62 | # dh_link
|
---|
63 | dh_strip
|
---|
64 | dh_compress
|
---|
65 | dh_fixperms
|
---|
66 | # dh_perl
|
---|
67 | dh_installdeb
|
---|
68 | dh_gencontrol
|
---|
69 | dh_md5sums
|
---|
70 | dh_builddeb
|
---|
71 |
|
---|
72 | # Build architecture-dependent files here.
|
---|
73 | binary-arch: build install
|
---|
74 | # We have nothing to do by default.
|
---|
75 |
|
---|
76 | binary: binary-arch binary-indep
|
---|
77 | .PHONY: build clean binary-indep binary-arch binary install install-indep install-arch
|
---|
Note:
See
TracBrowser
for help on using the repository browser.