Last change
on this file since 7574 was 4308, checked in by joerg, 17 years ago |
first version of debian package for josm
|
-
Property svn:executable
set to
*
|
File size:
1.4 KB
|
Rev | Line | |
---|
[4308] | 1 | #!/usr/bin/make -f
|
---|
| 2 | # Sample debian/rules that uses debhelper.
|
---|
| 3 | # GNU copyright 1997 to 1999 by Joey Hess.
|
---|
| 4 |
|
---|
| 5 | # Uncomment this to turn on verbose mode.
|
---|
| 6 | export DH_VERBOSE=1
|
---|
| 7 |
|
---|
| 8 | # This is the debhelper compatability version to use.
|
---|
| 9 | #export DH_COMPAT=5
|
---|
| 10 | export destdir = $(CURDIR)/debian/openstreetmap-josm
|
---|
| 11 |
|
---|
| 12 |
|
---|
| 13 | build: build-stamp
|
---|
| 14 | build-stamp:
|
---|
| 15 | dh_testdir
|
---|
| 16 |
|
---|
| 17 | # Add here commands to compile the package.
|
---|
| 18 | # $(MAKE)
|
---|
| 19 |
|
---|
| 20 | touch build-stamp
|
---|
| 21 |
|
---|
| 22 | clean:
|
---|
| 23 | dh_testdir
|
---|
| 24 | dh_testroot
|
---|
| 25 | rm -f build-stamp
|
---|
| 26 |
|
---|
| 27 | # Add here commands to clean up after the build process.
|
---|
| 28 | -$(MAKE) distclean
|
---|
| 29 |
|
---|
| 30 | dh_clean
|
---|
| 31 |
|
---|
| 32 | install: build
|
---|
| 33 | dh_testdir
|
---|
| 34 | dh_testroot
|
---|
| 35 | dh_clean -k
|
---|
| 36 | dh_installdirs
|
---|
| 37 |
|
---|
| 38 | ./debian/update_svn_revision.sh
|
---|
| 39 | ./debian/make_install_files.sh ${destdir} || exit -1
|
---|
| 40 |
|
---|
| 41 |
|
---|
| 42 | # Build architecture-independent files here.
|
---|
| 43 | binary-indep: build install
|
---|
| 44 | dh_testdir
|
---|
| 45 | dh_testroot
|
---|
| 46 | dh_installchangelogs
|
---|
| 47 | dh_installdebconf
|
---|
| 48 | # dh_installdocs
|
---|
| 49 | # dh_installexamples
|
---|
| 50 | dh_installmenu
|
---|
| 51 | # dh_installlogrotate
|
---|
| 52 | # dh_installemacsen
|
---|
| 53 | # dh_installpam
|
---|
| 54 | # dh_installmime
|
---|
| 55 | # dh_python
|
---|
| 56 | # dh_installinit
|
---|
| 57 | # dh_installcron
|
---|
| 58 | # dh_installinfo
|
---|
| 59 | # dh_installman
|
---|
| 60 | # dh_link
|
---|
| 61 | dh_strip
|
---|
| 62 | dh_compress
|
---|
| 63 | dh_fixperms
|
---|
| 64 | # dh_perl
|
---|
| 65 | dh_installdeb
|
---|
| 66 | dh_gencontrol
|
---|
| 67 | dh_md5sums
|
---|
| 68 | dh_builddeb
|
---|
| 69 |
|
---|
| 70 | # Build architecture-dependent files here.
|
---|
| 71 | binary-arch: build install
|
---|
| 72 | # We have nothing to do by default.
|
---|
| 73 |
|
---|
| 74 | binary: binary-arch binary-indep
|
---|
| 75 | .PHONY: build clean binary-indep binary-arch binary install install-indep install-arch
|
---|
Note:
See
TracBrowser
for help on using the repository browser.